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Exercise 2 - Getting Started

IMPORTANT! Before starting this exercise, please turn to appendix section at the back of your manual
and complete the Configuring Quantum GIS document.

Learning objectives: The purpose of this exercise is to become familiar with QGIS’s application
windows and graphical user interface, and the concept of a project document. You will have an
initial look at the basic tools and layouts within QGIS. We shall be working with a range of spatial
data for Kenya. Please feel free to explore the data beyond the instructions provided here,
experiment with functionality and ask if there is anything you don’t understand!

Part 1 - Open an existing QGIS project file and explore the
Graphical User Interface (GUI).

1. If not already done so, start QGIS.
— Click Start > All Programs > QGIS.... > QGIS Desktop 2.x
— You may see a QGIS Tip appear. One of these appears every time you start up the
software. Press OK to dismiss the tip.

2. Choose Project > Open

Browse to C:\Intro_Quantum_GIS\Exercises.

Select Exercise2.qgs and click Open.

You will now see a map of the East Africa region. This is a QGIS Project.

On the left hand side of the screen you will see a list of layers. This is the layer
panel.

You will see some group icons in the layer panel. These represent layer groups:

r‘;’

The map shows administrative boundaries in Kenya along with other topographic data
such as settlements (from Geonames, applying code PPL — populated place used), roads
(World Resource Institute source) and rivers (World Resource Institute source). Your
map will look similar to this.
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3. Click on the v icon next to a group (may display as a + or - in some versions of

QGIS). You will notice that all the layers from the group are now hidden in the layer window,
but still visible on the map. Click again to view the layers. Group Layers make it easier to

turn on and off several datasets at once.

4. Find the Administrative boundaries group in the Layer window.

- Click on the tick M@ Adminstrative boundaries

disappear from the map.

— Click on it again to make the layers re-appear.
— Practice turning on and off groups and individual layers.
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5. Open an attribute table.
— Find the layer Kenya_geonames_PPL.
— Right click on it and select Open attribute table.
@ rostars (" OpenAtiribute Table )
#_, Spatialite Fd ?oggle Editing
7 ArcGisFeatures
@ | eatureServer Save As..
@ ArcGisMapServer
) ows Save As Layer Definition File...
£ Tila Carvar MYz Filter...
yers Panel Show Feature Count
f._@ii.-"fﬁ.g'_sll?l‘ﬂ .
Properties
[] studyarea i,
; ename
— ke_major-rivers
— ke_major-roads
' ,_@ Adminstrative boundaries
[ xen_adm1
B ken_admaz
[ cntryo2
.,/ Kenya_geonames_PPL :: Features total: 2580, filtered: 2580, selected: 0 I (=] | = @
/BRI RD & A TVTESD DG s B =
geonameid name asdiname alternaten latitude longitude feature_c A
1 190188 Kusitawi Kusitawi Kusitawi -3.95010000000... 39.50723000000...
2 186088 Mto Panga Mto Panga Mto Panga -4.00000000000... 39.70000000000...
3 190191 Kusa Kusa -0.31680000000... 34.85152000000...
4 194292 Kanyarkwat Kanyarkwat 1.261860000000... 34.91328000000...
5 186092 Mtongwe Mtongwe Mtongwe -4.06642000000... 39.64108000000...
6 177896 Miritini Miritini Mirihini, Miritini -4,00961000000... 39.58456999999...
W
< >
| T Show All Features, El

There are several buttons along the top of the attribute table which we will be

looking at in more detail later in the course. For now just look at the table with its
rows and columns. Each row represents a different point (or feature) on the map.
The columns hold different information about the rows. The “name” column tells
you the settlement name that the point in the GIS it is representing.

Position the table so that you can see both the table and the map window; try
clicking a few of the row headers (circled above) and see if you spot the

corresponding yellow highlight on the map window — this visually locates each of the

settlements

6. Close the attribute table by clicking on the cross at the top right of the table.
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Part 2 - Navigating around the Map canvas

e The Map Navigation toolbar contains various tools to help you move around the map

canvas.
Zoom to native
pixel resolution Zoom Last
(for rasters)
Pan map Zoom to Refresh

selection Show
Bookmarks
Out \ \

SRR - CBCHER ¢ § OF O ¢

S T [ /]

V4 Full
Touch Zoom  £OOMTU

Zoom and In

Pan . Zoom to active
Pan map to selection layer extent

Zoom next
New Bookmark

1. Load the Map Navigation toolbar if it isn’t already open.
— View > Toolbars > Map Navigation

2. Zoom in to the Garba Tulla area, Isiolo County (highlighted yellow in the screenshot
below).

— Click on the Zoom in tool on the map navigation toolbar.

— Left click and hold and drag on the map to zoom in to the area shown within the
square below. As you drag the Zoom in tool on the map, you will see it draws a
temporary grey square over the area where you are zooming in

— Click on the Zoom last button. This will zoom back out of the map canvas to the
previous extent.

= You can also use the scroll wheel on the mouse to zoom in and out of the map
canvas. Practice doing this.
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3. Zoom back out to the full extent of the data.
— Click on the Zoom full tool.
—  You will notice that your map canvas zooms back to the full extent of all the
layers in your QGIS project, displaying the whole of eastern Africa

4. Click on the Pan Map tool. @
— Left click and hold on the map canvas and move the mouse. You will notice that
the map canvas moves accordingly.
— Try zooming in to the map using the scroll wheel and then panning with the Pan
Map tool. This is a very effective and quick way to navigate around your map.
— An alternative method for panning is to hold down the middle mouse button
(often the mouse wheel) and move the mouse.

5. Zoom to a specific scale.

— From the scale box at the bottom on the QGIS window, you are able to type in
your desired viewing scale. Type in a scale and press the ‘Return’ key on the
keyboard. You should see that your map canvas changes to the scale you typed
in.

-

Coordinate: -4.6497 506231 [Scale 1:479,867 _v] Rotation | 0.0 = ® Render @ EPSG:27700 Q

6. Right Click on ‘StudyArea’ in the layer window and select Zoom to Layer.
= You will see that the map canvas changes so that the Isiolo County is displayed.
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Part 3 - Create a Spatial Bookmark

1. Create new spatial bookmarks.
— Panand zoom to the Study Area located centrally on the map (red boundary).
0
— Click on the New Bookmark button. .
— Call this bookmark Isiolo County.
— Press the return key and click Close.

It will be useful to also have a bookmark for Kenya as a whole country
— Right click on KEN_adm_1
— Click on the New Bookmark button
— Call this bookmark ‘Kenya.’
— Press the return key and click Close ) ]
=Y
2. Zoom out to the full extent of the map using the Zoom full button. e

3. Use the Show bookmarks button to zoom back to the bookmark you just created.

]
= Click on the Show bookmarks button.

— The Geospatial Bookmarks window will open.
= You will see the bookmark you have just created (example below).

L) ]

DI T <
Name Project xMin yMin

Exerdse_l.qgs  36.626 -1.49832

— Select it and click on the Zoom to button circled above.
You will notice that your map zooms to the bookmarked area.
— Close the Geospatial Bookmarks window.

Note: Bookmarks are a good way to guide people around your map or to save important geographic
extents such as field survey sites and Areas of Interest.
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Part 4 - The Identify Features tool

e The identify feature tool provides a simple way of retrieving attribute data from map objects.
The tool is selected from the toolbar and is then used to click on map objects you want to
retrieve data for. The identify features tool retrieves the attribute data associated with the
active layer by default.

1. Use the Identify Features tool to view the attributes for a map object. ‘i‘\"

In the Layers window, click the Kenya_geonames_PPL layer to make it the active layer
Pan and zoom in to your map until you are able to see one or more points from the
Kenya_geonames_PPL layer.

Select the Identify Features tool and click on one of the Kenya_geonames_PPL
points.

You will notice that the point you selected is highlighted in red.

You will see that a new window pops up displaying all the attributes for the polygon you selected.

Identify Results n
& _f J = ]
Feature Value ;I
= Kenya_ageonames_PPL
m—
(Derived)
(Actions)
geonameid 180533
name Sericho
asdiname Sericho
alternaten Saricho,Sericho
latitude 1.083330000000000
longitude 39.083329999999997
feature_d P
feature_co FPL o
country KE
ol KE
adminl 3
admin2 ]
admin3 0 @
ardming 0

Mode | Current layer - Auto open form

Try viewing the attributes for a few more points from the same layer until you are
happy with how this works.

Close the Identify Results window.

Try to view the attributes for one of the polylines in the ke_major-rivers layer.

If you don’t see the data you were expecting, make sure that the correct layer is
highlighted in the Layers window.
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Part 5 - Accessing QGIS Help

1.

Move your mouse over the buttons on the QGIS toolbar. A yellow pop-up help box will
appear.

View Layer Settim
L[

Similar to Windows’ ‘Tool Tips'

2. Click the button Help contents from toolbar (if it is visible), or alternatively select it
from the Help drop-down menu

This starts a web browser displaying QGIS online documentation; it is important to
get familiar with this support site

A PDF is available for download and is updated regularly

Explore some vital QGIS functions: hover your mouse over the following buttons to identify

them and explore the Help contents documentation to learn what they do. In the space
below, provide some brief details:

Button

Description
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Part 6 - Browse for data
1. Browse fOf' vector data

— Click on the Add Vector Layers button . G
— Set up the window as below and click on Browse

& Add vector layer [ =]
Source type
Directory Database Protocol

Encoding  System -

Source

e

— Next to the File name: drop-down there is another dropdown menu. Click on this.

ESRI Shapefiles (*.shp *.5!

GPS eXchange Format [GPX] (*.gpx *.GPX)
GPSTrackMaker (*.gtm *.gtz *.GTM *.GTZ)

Exercises » Data » Vector » GADM v O GeoJSON (*.geojson *.GEQJSON)

GeoPackage (".gpkg *.GPKG)

GeoRS5 (“xml *XML)

A Geoconcept (*.gut *.bat *.GXT *.TXT)

Name Date modified Geography Markup Language [GML] {*.gml *.GML)

Geography Markup Language [GML] (*.gml *.GML)
Geospatial PDF (*.pdf *.PDF)

Hydrographic Transfer Format (*.htf *.HTF)
INTERLIS 1 (*.itf *.ornl *.ili *.ITF * XML *.ILI)
INTERLIS 2 (*.itf *orl *.ili =] TF *XML *.ILI)

Keyhole Markup Language [KML] (*.kml *.kmz *.KML *.KMZ)
MS Excel format (*xls *.XL5)

M5 Office Open XML spreadsheet (*xlsxc * XL5X])
Mapinfo File (*.mif *tab . MIF *.TAB)

Microstation DGN (*.dgn *.DGN)

MAS - ALKIS (*aml *XML)

Open Document Spreadsheet (*.ods *.0D5)
Opendir Special Use Airspace Format (*.bd *.TXT)
OpenStreetMap (*.osm *.pbf *.05M *.PEF)

PCl Geomatics Database File (*.pix *.PIX)

5-57 Base file (*.000 *.000)

SEG-P1 (*.seg *.seq1 *.sp1 *5EG *.5EG1 *.5P1)
SEG-Y (*.sgy *.segy *.5GY *.SEGY)

SOLite/Spatialite (*.sqlite *.db *.sglite3 *.db3 *.s3db *.513 *.5QLITE *.0B *.50LITE3 *.DB3 *.53DB *.5L3.
Scalable Vector Graphics (*.svg *.5VG)

Special Use Airspace Format (*.sua *.5UA)

£

[ KEN_admO.shp 03/1172015 20
[ ] KEN_adm1.shp 5
[7] KEN_adm2.shp
[7] KEN_adm3.shp

)
- | |ESRIShapefiles (*.shp *5HP)  ~

Open Cancel

— This shows you all the different vector file formats QGIS is able to open.
— Different file formats will be covered in more detail later on the course.
— Close the Browse window and the Add vector Layer window.
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2. Browse for Raster data

— Click on the Add Raster Layer button. ©

— Next to the File name dropdown there is another dropdown. Click on this

[GDAL] All files (%) (*.*) =
[GDAL] ERDAS Compressed Wavelets (*.ecw *.ECW)
[GDAL] ERDAS JPEG2000 (*jp2 *.j2k *.JP2 * J2K)
[GDAL] MrSID Generation 4 / Lidar {*wview *VIEW)
[GDAL] Multi-resolution Seamless Image Database (*.sid *.5I07)
L [GDAL] Virtual Raster (*.vrt *.VRT)
[GDAL] GeoTIFF (*.tif *.tiff *.TIF *.TIFF)
[GDAL] Mational Imagery Transmission Format (*.ntf *.NTF)
v |44 [GDAL] Raster Product Format TOC format (*.toc * TOC)
= [GDAL] Erdas ImagineImages (*.img *IMG)
[GDAL] Ground-based SAR Applications Testbed File Format (*.gff *.GFF)
[GDAL] Arc/Info Binary Grid (hdr.adf HDR.ADF) (hdr.adf:HDR.ADF)
= [GDAL] Arc/Info ASCH Grid (*.asc *.ASC)
[GDAL] SDTS Raster (*.ddf *.DDF)
[GDAL] DTED Elevation Raster (*.dtD *.dtl *.dt2 =.0T0 *.DT1 =.0T2) .
[GDAL] Portable Metwork Graphics (*.png *.PNG)
[GDAL] JPEG JFIF (*,jpg *.jpeg *JPG *JPEG)
[GDAL] Japanese DEM (*.mem *.MEM]
[GDAL] Graphics Interchange Format (*.gif *.GIF)
[GDAL] Graphics Interchange Format (*.gif *.GIF)
[GDAL] Envisat Image Format (*.nl *.N1)
[GDAL] ¥11 PixMap Format (*xpm *.XPM)
[GDAL] MS Windows Device Independent Bitmap (*.bmp *.BMP]
[GDAL] PCIDSK Database File (*.pix *.PLX)
[GDAL] PCRaster Raster File (*.map *.MAP)
[GDAL] ILWIS Raster Map (*.mpr *.mpl *.MPR *.MPL)
[GDAL] 5GI Image File Format 1.0 (*.rgb *.RGE)
[GDAL] SRTMHGT File Format (*.hgt *.HGT)
" [GDAL] Leveller heightfield (*.ter *. TER)
— [GDAL] Terragen heightfield (*.ter * TER) -

A [[GDAL]AI.I.ﬁI.es("}(".*} .] I

m

[ open || cancel |

= e —— 1

This shows you all the different raster file formats QGIS is able to open.
— Close the Add Raster Layer window.
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Part 7 - Browse for plugins
NOTE FOR THIS PART OF THE EXERCISE YOU WILL REQUIRE AN INTERNET CONNECTION

By default no plugins are active, but many plugins are pre-installed with QGIS. You can add
many more, covering many different types of analysis, to further enhance functionality.

1. Click on Plugins > Manage and Install Plugins
— This opens the QGIS Plugin Manager.
— Click on the Installed tab
— Plugins with a cross next to them are currently activated.
— Plugins without a cross are currently not loaded.

Plugin
Activated
,i’ Plugins | Installed (20) v 23
7z Search [ ]

[]-+: Coordinate Capture Installed Plugins

[“1E3 DB Manager

[ 7y Dxf2Shp Converter Here you only see plugins installed on your
&evis QGIS.
W) GdalTools Click on the name to see details.

[]5 Geometry Checker Click the checkbox or doubleclick the name to

[] %2 Geometry Snapper activate or deactivate the plugin.

D_}Gwefe,m GDAL You can change the sorting via the context
%= GPS Tools menu (right click).

1 1%
Heatmap

] Interpolation plugin

[A -+ MetaSearch Catalogue Client

[[]  OffineEditing

(] Orade Spatial GeoRaster

[+/] @ Processing

[]@ Raster Terrain Analysis plugin

[ .. Road graph plugin

(7 Spatial Query Plugin
[] @ Topology Checker
[]* Zonal statistics plugin

Plugin
deactivated

| | Upgradeall = Uninstall plugin Reinstall plugin
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,f Plugins | Not installed (474

o Al

Lg]
F : Installed

B rotinstaled

Search |

(7]

E

- Accuracy Assessment

4 AccurAssess

. Aequilibrak

i+ Affine Transformations

i+ AGT - Archaeological Geop
#¢ AmigoCloud

4+ Anaximandre

#+ Another DXF Importer / DXF2S|
# ArcheoCAD

# Area Along Vector

# Arrows

J Attribute based dustering

# Attribute painter

# AutoFields

#+ autoform

4 autoSaver

# AutoTrace

# Azimuth and Distance Calculatc
J¢ Azimuth and Distance Plugin

J+ Backup layer

44 Batch GPS Importer

i+ beePen

i+ BGT Import

# BLN Exporter

#+ BoundingBox

#& Buffer by Percentage

i Cadasta

# cadastre

#+ CADDigitize

L FadTanls

~ | |Not installed plugins

Here you see the list of all plugins available in
the repositories, but which are not yet
installed.

Click on the name to see details.

You can change the sorting via the context
menu (right click).

A plugin can be downloaded and installed by
clicking on it's name, and then click the 'Install
plugin' button.

v | Upgradeal Uninstall plugin Reinstall plugin

— This tab shows you a list of plugins available to download and install.
— Each plugin has a description field which tells you a bit more about what it does.
You will install some of these during this course.

= Close this window.

=
3. Save your QGIS project
4. Close QGIS

Challenge

00.jpg

e Create a new QGIS project and add the following datasets to it.
- C:Intro_Quantum_GIS\Exercises\Data\Vector\OSM\Isiolo\Line_Watercourses.shp
- C:Intro_Quantum_GIS\Exercises\Data\Raster\BlueMarble\world.200410.3x21600x108

Hint — remember the file type options available from the drop down menus.
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