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Exercise 8b - Generate summary
statistics from raster data

Learning objectives: The purpose of this exercise is to outline a method of generating summary
statistics (min, max and mean) from a raster dataset by aggregating pixel values to a defined area
(typically administrative or census units). This procedure will introduce the Zonal Statistics
geoprocessing tool.

We will use population count grid data for two provinces in Nigeria. These datasets have been
generated using the methods under discussion in this workshop. Initially we will prepare the data
by combining raster datasets of two provinces into one, using the Merge geoprocessing tool. After
generating zonal statistics we will produce a thematic population map.

Skills you will learn
e Merge two datasets together
e Zonal statistics
e Vector styling
e Buffer Tool

Part 1 - Merge (mosaic) raster datasets.

1. Open an existing QGIS project file from the following location:
— C:\Intro_Quantum_GIS\Exercises\Exercise_8b.qgs

& QGIS 283-Wien - UNFPA_Exercise2 2
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The raster datasets within the POP GRIDS folder represent two neighbouring provinces in Nigeria.
The maps represent people per pixel in these two areas and consequently there are two separate
scales of values (0 to 403 and 0 to 842), as displayed in the legend. Converting the two areas into a
single raster would establish a single standard scale. This would clearly provide a better
representation of population values across the combined region. In addition, it is an essential step in
generating zonal statistics for the whole area.

2. Merging (mosaic) multiple datasets into a single dataset
— From the Raster drop-down menu, select Miscellaneous > Merge
— In the dialog box that appears, click Select button, to the right of Input files
— Browse the following location:
C:\Intro_Quantum_GIS\Exercises\Data\Raster\WorldPop

i ™y
/" Select the files to Merge l&]
@uv| . « Data » Raster » WorldPop » v|¢,|| Search WorldPop }Dl

Organize = MNew folder ==« [ .j@.
i MName Date modifiec
- Libraries P
B " || KadunaPOP.tfw 03/02/2016 13,
=| Documents
iv Musi & KadunaPOP.tif 03,/02/2016 13
@' Music =
- 2| KadunaPOP.tif aux.xml 05/02/2016 13,
k=| Pictures
§ - || KadunaPOP.tif.ovr 03/02/2016 13,
ideos
|| KadunaPOP tif vat.dbf 03/02/2016 13
W C (UOS-210708] L || KadunaPopulation.tif vat.cpg 03/02/2016 13
1% Computer - =
i p || kanoPOP tfw 03/02/201613
& OSDisk (C:) |
WorldPOP (E) & kanoPOP tif 03/02/201613
=a Worl . . e
2] kanoPOP.tif.auxxml 05/02/2016 13
5 GIS (\\geodataresearch.files.soto = . I
| | kanoPOP tif.ovr 03/02/201613 ~
¥ resource () - 4 T 3
File name: » | Allfiles (*) (*) -
EUMETSAT Archive native (*.nat *.NAT) -

Envisat Image Format (*.n1 *.M1)

Erdas Imagine Images (*.img *IMG)

b FARSITE v.4 Landscape File (*.lcp *.LCP)
GMT MetCDF Grid Format (*.nc *.NC)
GRIdded Binary (*.grb *.GRB)
GeoPackage (*.gpkg *.GPKG)

GeoSoft Grid Exchange Format (*.guxf *.GXF)

Geospatial PDF (*.pdf *.PDF)

Golden Software 7 Binary Grid (*.grd *.GRD)

Golden Software ASCI Grid (*.grd *.GRD)

Golden Software Binary Grid (*.grd *.GRD)

Graphics Interchange Format (*.gif *.GIF)

Graphics Interchange Format (*.gif *.GIF)

Ground-based SAR Applications Testbed File Format (*.gff *.GFF)
HF2/HFZ heightfield raster (*.hf2 * HF2)

Hierarchical Data Format Release 4 (*.hdf *HDF) e
Hierarchical Data Format Release 5 (*.hdf5 *.HDF5)

m

— Click the All files drop-down menu and select GeoTIFF

— Hold down Ctrl on your keyboard and select KadunaPOP.tif and KanoPOP.tif

— Click Select button, to the right of Output file and save the output as follows:
C:\Intro_Quantum_GIS\Exercises\Data\Output_data\POP_Kano_Kaduna.tif

— Click to enter an X in the No data value option, and type -32768 (this is the
designated value assigned to no data pixels in the input rasters)

— You dialog box should look as follows:
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,f' Merge "@" 3

Choose input directory instead of files

Input files eriWorldPopikanoPC Select...
Cutput file P_Kano_Kaduna. tif Select...
® Mo data value | -32753 -
Place each input file into a separate band
Use intersected extent
Grab pseudocolor table from the first image
[ 3 Creation Options
¥ Load into canvas when finished
gdal_merge.bat -n -32768 -a_nodata -32768 -of E]

GTiff o

G: JLiveDataUC0800_GIS_Training/COURSES,BES D
POKE/UNFPA_HQ _MewYork /Exerdses /Data/Outpu
t_data/POP_Kano_Kaduna. tif G:
\LiveData\UCO800_GIS_Training\COURSES\BESPO

EEW IKMEDA HM hlawVark-iEvarcscac \Dizstz D actark

— Click OK

As you will see the merged dataset is presented in a black to white ‘stretched’ style. Follow the
procedure illustrated in the screenshot to copy the style from KanoPOP to the new dataset:

f' QGIS 2.8.3-Wien - Nigeria_Screenshots Flun on o - o ‘1*

Project Edit View Layer Settings Flugins Vector Raster Database Web Processing Help

O J HAMB 2L ARNDO QG G- & =D e B Y
e W[ gy E W @ @ o ﬂ) A (7 \@ %
oPEDPDY s BB
| Layers
e w PEE
(Et{! ] x'.l' POP_Kano_Kaduna.tif [~]
0

0.000000 A2 Zoom to Layer
210.500000
421.000000
631.500000 Zoom to Best Scale (100%)

842.000000 -
BX KadunaPOP Stretch Using Current Extent
0.000000 = Remove

Show in overview

100750000 .
201.500000 |l Duplicate

302.250000 o
403.000000 Set Layer Scale Visibility

e
I}
\z)
/
Vo
L
%,
% Kano over3Q Set Layer CRS
@
2
i
g
V)

Identify Re

A EH @ =

2 ka Save As Layer Definition File... Rename Current
g 2

Set Project CRS from Layer

Save As...

Properties %| (default)

Rename

— Richt-click KanoPOP > Styles > Copy Style
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— Right-click POP_Kano_Kaduna > Styles > Paste Style

. QGIS 2.8.3-Wien - UNFPA Exercise2

Project Edit View Layer Settings Plugins Vector Raster Database Web Processing Help

DEEBRGR A0 EL,LAPLRARKR Qe - - e EEm-O 3 -

4/BRART~0 0 =maswss & & UL SS » b
sididlli i M
| Layers N
= « YE @ 3
ritﬂ B[ POP Kano Kaduna
o= | 0.000000
L 210.500000
3@ 421.000000
& 631.500000
842.000000
l X ] nigeria_states
B Kano_Kaduna
=% (@ POP GRIDS
B kanoPOP
] 0.000000
o 210.500000
421.000000
‘n [ 631.500000
- [ 842.000000
_f}, ©-% ta¥ KadunaPop
0.000000
R 100.750000
201.500000
@, 302.250000
q’ |l 403.000000
%
AVas
a8
@
[ig3

The raster dataset now presents a more accurate distribution of population counts across these two
states using a single consistent value range (0 to 842 persons); the raster can now be fed into the
zonal statistics tool.

Part 2 — Analyse raster population data using Zonal Statistics tool

1. We will use the Zonal statistics tool to calculate mean, min and max pixel values per Ward
administrative level. The tool will calculate statistics using the raster data and return the
results into the attribute table of the ward boundary data

— First of all, drag layer POP_Kano_kaduna into the group folder POP GRIDS
— Then make the following dataset visible: Kano_Kaduna
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F: QGIS 2.8. 1- | cise?

Project Edit View Layer Settings Plugins Vector Raster Database Web Processing Help

NEBROR AP EFLPHPLLAR/ARC Qe- M- e B8e-0 B
A /BRRATG 20 "M 2% &~ & 8080 MMS%MENH D@
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Layers T~
0 = P EE L

i[9 D Nigeria_States

i[9 Kano Kaduna

=% [l POP GRIDS

- POP_Kano_Kaduna
0.000000
210.500000

421.000000

- 631.500000
- [l 842.000000

g- kanoPOP
- 0.000000

210.500000
421.000000

631.500000
842.000000
= KadunaPOP

0.000000
100.750000
201.500000

- 302.250000
- | 403.000000

4

ESPL088MVNANARNS BS 6o

— Go to drop-down menu Raster > Zonal Statistics > Zonal Statistics

|F‘.aster| Database Web CADDigitize Processir

% Raster Calculator... =
; B &= |

Georeferencer r

T S

Interpolation r - 4 -
i @ Terrain Analysis

Zonal statistics Zonal statistics

Projections g

P e i [
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Complete the dialogue box as below

Any text entered into the Output column prefix box will prefix the new fields which
will be generated in the attribute table of the Kano_Kaduna Ward level boundary
data. The suggested prefix ZS_ will help to differentiate these calculated fields from
others in the table

" Zonal Statistics [ % || == |
Raster layer:

POP_Kano_Kaduna -
Band Band 1 -

Polygon layer containing the zones:
Kano_Kaduna -
Cutput column prefix:

7s_

Statistics to caloulate:

¥ Count
¥ Sum

X Mean
Median
Standard deviation
Minirmum
Maximum
Range
Minority
Majority
Variety

We will accept the default statistics but feel free to select additional stats, if you
wish

Click OK to run the tool

Open up the attribute table for Kano_Kaduna and clarify the calculations that have
been performed:

Name: unique ID for each grid square

ZS_count: count of the number of pixels from the population data that fall within
each ward

ZS_sum: sum total of the population values for all pixels within each ward
ZS_mean: mean of the population values for all pixels within each ward

ZS_min & ZS_max: min and max individual pixel value within each ward

Page 6 of 12



UNIVERSITY OF

Southampton

;’

LRt

Kano_Kaduna :: Features total: 736, filtered: 736, selected: 0

= =]=]

/) 2B @ & kT E S D8 B | =

| HAPE_Leng SHAPE_Area Z5_rcount Z5_sum Z5_mean Z5_min Z5_max ﬂ
1 0.372364510304... 0 0 0

2 [D096935436... [ 0.006288655305. . 9043 12858 | 1.4210875331565 102

3 [1300335994... [ 0.012101818660... 17427 10683 | 0.613014238173... 109

4  |D633247551... [ 0.008322307569... 11989 7558 | 0.630411210276... 113 :

(4]

[ T show All Features ']

Part 3 - Thematic symbology

1. Symbolise the data to show the sum (or total) population for each ward

— Right-click Kano_Kaduna and select Properties

— Select Style tab

— Complete the configuration as shown below; alternatively decide for yourself
regarding colour ramp, number of classes and mode of value distribution

IMode Natural Breaks (Jenks) vI

.)’5 Layer Properties - Kano_Kaduna | Style @
= Graduated I hd
@’ Style I Column 1.2 75_sum I -
€I Labels Symbol Change...
E Fields Legend Format | 241 - %62 : Trim
» Method Color A
Rendering
I Color ramp - ¥lorRd I - Edit Invert
@ Actions
Classes Histogram |
4 .
¥ -ons Symbal |\falues Legend
o 0.00 - 14705.00 0 - 14705
|ﬂ Diagrams
o 14705.00 - 24130.00 14705 - 24130
r, o 24130.00 - 34511.00 24130 - 34911
1 Metadata % 3491100 - 50044.00 34911 - 50044
o 50044.00 - 70565.00 50044 - 70569
Variables % 70569.00 - 99577.00 70569 - 99577
o 99577.00 - 145973.00 99577 - 146973
Legend o 146973.00 - 196797.00 146973 - 196797
o 196797.00 - 293805.00 196797 - 293305
o 293805.00 - 532049.00 293805 - 532049

Classe

Draw effects

Control feature rendering order

Style T

Cancel

Classify BE | | = Delete all Advanced ~
X/ Link dass boundaries
w Layer rendering
Layer transparency C [u] :
Layer blending mode MNormal
Feature blending mode Mormal

Help
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— The suggested settings should generate a map like this:

&G 21817 - Freecine T
Proect Bt Wew  Layer Seftngs Pugns Wi ster  Datstase  Web  CADDgRge  Prooesrg  Hep
T, 5 .+ [ S —— — - [
BBOR 06 H-&- REEZL =4 0|

) n
& 40 <C
Rl @ w R W I e P
| o o M | 3 ED - . b
“PHa9ssee AlaCs o B+ D o
¥y /e % ~SB k@ e x
Ly Panal &
Vo  eamya-zsrn
=B
ﬁ x - 1475
x 14705 - 34130
'c:' x| el
x| e om0
a" % 0 moM - mssn
x B s - sasyr =
Q x W marr e
o x 16973 - PETT
Mg T x [l 19577 205
9 x [l mames . smos
CRNEE
& |
=
4
Statibs Pars &=
Kara_adna -
13 75 e e
stasstc s :
Count ™%
Sem 276972 407
Hean gr =
Hedan ®711
st dev (pop) 17063 -
Selecied features oy 2 |
Coordeate 10585,

With thematic maps such as this, displaying polygons of relatively detailed spatial resolution, it is

often useful to remove to remove polygon borders to better illustrate the distribution, so we’ll
return to the Style tab.

- Right-click Kano_Kaduna and select Properties
- Select Style tab

- Click the Change button, to the right of Symbol

i) Layer Properties - Kano_Kaduna | Style @

= Graduated

-
Column 1.2 75_sum -
€T Labels Symbol I Change... I
E Fields Legend Format | 241 - %2 Precision 0 : Trim
Method Color -
Rendering
- Display Color ramp - YlorRd - Edit Invert
@ Actions
Classes Histogram |
% s
¥ -oins Symbol " |Values Legend
l“ S » 0.00 - 14705.00 0 - 14705
Diagrams ® 14705.00 - 24130,00 14705 - 24130
r, » 24130.00 - 34511.00 24130 - 34911
1 Vetadats ® 3491100 - 50044.00 34911 - 50044
o 50044.00 - 70569.00 50044 - 70569
Variables x 70569.00 - 99577.00 70569 - 99577
o 99577.00 - 146973.00 99577 - 1465973
Legend o 146973.00 - 196797.00 146973 - 196797
o 196797.00 - 293805.00 196797 - 293805
o 293305.00 - 532049.00 293805 - 532049
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— Inthe dialog box that appears, click Simple fill, to bring up Fill and Outline options
— Click the down arrow for the Outline drop-down menu and select Transparent Border

— Click OK

.r‘! Symbol selector

=
o Simplefill

&|[=][a]3][a][¥]

[7 =]

Symbol layer type

Simple fill b

Fil [

Outline [

— This produces a much cleaner image, as below

o

Layers Panel

Project Edit View Layer Settings Plugins Vector Raster Database Web CADDigitize Processing Help

DEBRGR Qe K-&-LEEI=C T A0 FLAPPALMN)
=0 E=

% Al Q 4

¢f|@:i;fﬁ"vﬁtﬁ‘ﬂ
x
x

(- Kano_Kaduna

-3 ) Kano_Kaduna
g} X 0-14705
x 14705 - 24130
'u - ® 2413034811
® | 34911- 50044
@ e x 50044 - 70569
® | | 70569-99577
% ® | 59577 146973
® 146973 - 196797
@ v ®x B 196757 - 293805
9 % [l 293805 - 532048
&%/ [ Pop GRIDS
(e
‘V;; <
&
&
@
Statistics Panal

1.2 7S_sum
Statistic Value

Count 736
Sum 2,76972e +H07
Mean 37632.1
Median 26711
St dev {pop) 43706.2

Selected features only

4
(m)
5o 45

0
Hem

Zamfara

-3 L HEPHEE MO 6

Coordinate 8.641,12.5|
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Part 4 - Taking it a step further...

Zonal Statistics is a very useful tool but often you will want to define your own boundaries.
We will now bring in some vector point data for hospital locations in Kano and Kuduna
states. We will generate a buffer around each one and then apply zonal statistics to help us
estimate catchment populations for each buffer.

1. Add vector point data
- Goto Layer drop-down menu > Add Layer > Add Vector Layer
- Browse to the following location and select these data:
C:\Intro_Quantum_GIS\Exercises\Data\Vector\Nigeria\Kano_Kaduna_Health_Facilities.shp

Jigawa

Zamfara

- The points represent main hospitals in the two states

2. Buffer the hospitals to approximately 30km. (Estimates for health facility catchment
vary but 30km is a good measure for assuming a combination of walking and some form
of motorised transport to the health facility.)

- Open up the Processing toolbox if is not already present: Click on the Processing
drop-down menu > Toolbox

- Within the ‘Search...” window of the toolbox, type in Buffer

- From the filtered results, double-click Fixed Distance Buffer
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Processing Toolbox (][]
buffer
iRecently used algorithms
b i GDALJOER [45 geoalgarithms]
[=H [DER] Geoprocessing
;‘.'. Buffer weckaors
;‘.'. Single sided buffers (and offset lines) for lines
El- g GERASS commands [161 geoalgorithms)
=l Raster {rn*)
& nhbuffer - Creates a raster map layer showing buffer zone...
= Meckor (v, *)
& w.buffer.colurnn - Creates a buffer around Features of giv...
4 w.buffer.distance - Creates a buffer around Features of gi...
El- g GRASS GIS 7 commands [315 geoalgarithms]
=~ Raster (1*)
3 nbuffer - Creates a raster map laver showing buffer zone...
¥ nrbufferlowmernn - Creates a raster map layer showing buf...
[=h Yeckaor (v, *)
& wbuffer.colurn - Creates a buffer around Features of giv...
& wbufferdistance - Creates a buffer around Features of gi...
B # ©als geoalgaorithms [117 geoalgarithms]
B
™ Fixed distance buffer
F wariable distance buffer
B &5 saGA (2.3.2) [324 geoalgorithms]
[ Raster tools
@- Raster buffer
@- Raster proximity buffer
@- Threshold raster buffer
[=1 Yector general bools
@- Fixed distance buffer
@- ‘ariable distance buffer

- In the tool window that appears, complete the parameters as follows:

7 Fixed distance buffer | % [ =2

Parameters | Log Run as batch process... | Fixed distance buffer

Input laver This algorithrn cormputes a buffer area For all the
: features in an input laver, using a fixed distance.
| kano_Kaduna_Health_Faciities [EPsci43ze] v | ... ]

Diskance

"

Segments

FY
: o]

Dissolve result

Buffer
I'k,fE><eru:ises,l'Data,l'Output_data,fhnspitals_Ska_I:uuFFer.shp IE]

| Open output file after running algarithm

0% |

I Fun ]" Close I
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- Note that 0.28 is a measurement in angles (degrees of Latitude/Longitude) and
equates to approximately 30km

- Select an output location for your buffer shapefile, as suggested

- Click Run

- Click Close

- Now inspect the hospital buffers which will have appeared in the layer list (note that
it’s display name will be simply Buffer

Challenge

This polygon dataset is now the equivalent of the Kano_Kaduna admin areas layer which
you used in the zonal statistics section earlier (part 2). Using what you have learnt, refer
back to the procedure in Part 2 and generate zonal statistics for each hospital
catchment.

- According to the population data, which hospital has the largest catchment
population, and which has the smallest?
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